Скрыть объявление
Вышла новая версия XenForo 1.5.13 Nulled By XenForo.Info. Поспешите обновить свои форумы на новую версию прямо сейчас!

Как настроить подтягивающуюся картинку при кросс-посте в соц.сети

Тема в разделе "[1.x] Техническая поддержка", создана пользователем RealKot, 8 апр 2016.

  1. TopicStarter Overlay
    RealKot

    RealKot Проверенные

    Сообщения:
    95
    Симпатии:
    81
    Пол:
    Мужской
    Подскажите, пожалуйста, как убрать\заменить дефолтную картинку на свою при кросс-постах в соц.сети?

    Снимок.PNG
     
  2. Skaiman

    Skaiman Проверенные

    Сообщения:
    7106
    Симпатии:
    12429
    Пол:
    Мужской
    styles/default/xenforo/logo.og.png
     
    Raynar, Hope и Mirovinger нравится это.
  3. Neora

    Neora Проверенные

    Сообщения:
    95
    Симпатии:
    36
    я как понимаю, нужно подождать, чтобы в социальных сетях отражался новый лого?
     
  4. Skaiman

    Skaiman Проверенные

    Сообщения:
    7106
    Симпатии:
    12429
    Пол:
    Мужской
    Можно и не ждать :-) если назвать файл логотипа по другому, например logo.og1.png, а может просто заменил в дефолтном, а используешь другой стиль :-)
     
  5. TopicStarter Overlay
    RealKot

    RealKot Проверенные

    Сообщения:
    95
    Симпатии:
    81
    Пол:
    Мужской
    нет, соц.сети подтягивают раз и навсегда, надо вручную обновлять
     
  6. Skaiman

    Skaiman Проверенные

    Сообщения:
    7106
    Симпатии:
    12429
    Пол:
    Мужской
    Адрес картинки там какой?

    Только что на фейсбук проверил, нормально все

    Ну старые да

    Делаешь свою картинку, называешь ее logo.og_1.png меняешь в дефолтном стиле, в настройках стилей, всех, прописываешь один путь styles/default/xenforo/logo.og_1.png
     
    Mirovinger и RealKot нравится это.
  7. Neora

    Neora Проверенные

    Сообщения:
    95
    Симпатии:
    36
    я старую удалил, новую сделал с таким же названием. Обновилось ближе к вечеру в фейсбуке и вконтакте
     
    Hope нравится это.
  8. evgen583

    evgen583 Проверенные

    Сообщения:
    490
    Симпатии:
    41
    Пол:
    Мужской
    А где именно в настройках стиля прописывать путь
     
  9. Nappsel

    Nappsel Проверенные

    Сообщения:
    1008
    Симпатии:
    2233
    evgen583, наверное имелся ввиду путь: Настройки стиля"Шапка" (header) и навигацияЛоготип Facebook Open Graph.
     
    Hope нравится это.
  10. evgen583

    evgen583 Проверенные

    Сообщения:
    490
    Симпатии:
    41
    Пол:
    Мужской
    Спасибо за подсказку, уже разобрался.
     
  11. bphmth

    bphmth Проверенные

    Сообщения:
    196
    Симпатии:
    146
    подскажите, может кто-то сталкивался, после переезда на другой хостинг, не отображаются картинки при репостах в социальные сети, хотя в "Настройки стиля – "Шапка" (header) и навигация – Логотип Facebook Open Graph." всё без изменений...

    я пробовал уже добавить новую картинку с другим именем и тоже результата никакого, при этом логотип форума, который лежит в той же папке и располагался по тому-же пути, работает без проблем

    в чем может быть беда?
     
  12. Nappsel

    Nappsel Проверенные

    Сообщения:
    1008
    Симпатии:
    2233
    Открою вам небольшой секрет: картинка вытягивается из тега og:image что внутри <head>. Хотите проверить что будет отображаться для нужной страницы, откройте исходный код и найдите указанный тег. Если на форуме он правильный, а соц. сети показывают старый, то это уже кэширование с их стороны. Вроде бы в vk и fb были инструменты сброса кэша.
     
    Exile и bphmth нравится это.
  13. bphmth

    bphmth Проверенные

    Сообщения:
    196
    Симпатии:
    146
    я сбрасывал кэш, вот тут есть подобная услуга
    Пожалуйста, войдите или зарегистрируйтесь для просмотра скрытого текста.


    ранее всегда сбрасывалось и показывалось мгновенно, даже если не сбрасывалось, то была видна старая картинка, а сейчас картинки просто нет, никакой и произошло это исключительно после переезда, хотя в паке она лежит, путь к ней прописан, ошибок связанных с новой mysql вроде бы нет, до вчерашнего переезда всё отображалось корректно, вот и хочется выяснить, что могло пойти не так

    Разобрался с проблемой, на хостинге подсказали посмотреть права папок с изображениями, посмотрел, теперь всё работает ) может будет подсказкой для тех кто переезжает и столкнётся с подобной траблой
     
    Hope нравится это.
www.megastock.ru

Email: XenForo.Info@yandex.ru. Skype: XenForo.Info